Back to news

*-dev: Libpri version for 1.6 Asterisk

#
Author: Matt Riddell
Daily Asterisk News
Ask Question

Matthew Fredrickson has posted details on which version of libpri to use with Asterisk 1.6:

Public Service Announcement :-)

Just to make it clear to everyone who may be confused by the recent libpri activity (removal of the 1.6.0-beta tarball and links, among other things), a mistake was made when the libpri-1.6.0-beta tarball was created.

We are not planning on releasing a 1.6 version of libpri, but instead you need to use the recently released version 1.4.4 of libpri with Asterisk 1.6. There were not big enough changes for Asterisk 1.6 to require a major ABI change release of libpri, so instead most of the 1.6 specific functions were back ported to the 1.4 branch of libpri (including BRI support, as well as a few other things such as TBCT for Q.SIG)

For Zaptel, you still only need a 1.4 release.

Hope that clears the air a bit for anyone out there who were not aware of what was going on.

--
Matthew Fredrickson
Software/Firmware Engineer
Digium, Inc.


Comments


Related posts

Back to top

Ready to supercharge your business?

Dialer pricing from only $300 per month!